PhpMyAdmin & PHP 7.2 – Eccezione #551.

1
2628
lo sviluppatore deve essere la cattiva coscienza della sua applicazione | ©Marco Tomassini

L’eccezione “Warning in ./libraries/plugin_interface.lib.php#551” deriva dalla incompatibilità tra PhpMyAdmin v4.6.6 e PHP 7.2.

Se per qualsiasi motivo non si intende aggiornare PhpMyAdmin all’ultima versione, ma si vuole comunque risolvere questo problema, occorre seguire questi passaggi:

Aprire il Terminale ed eseguire il backup del file plugin_interface.lib.php

$ sudo cp /usr/share/phpmyadmin/libraries/plugin_interface.lib.php /usr/share/phpmyadmin/libraries/plugin_interface.lib.php.bak

Modificare il file plugin_interface.lib.php utilizzando l’applicazione nano

$ sudo nano /usr/share/phpmyadmin/libraries/plugin_interface.lib.php

Premere CTRL + W per attivare la ricerca e digitare la stringa di codice

(! is_null($options) && count($options) > 0) {

in alternativa, nel caso in cui non venga trovata, digitare

($options != null && count($options) > 0) {

Sostituire la stringa di codice trovata con:

($options != null) {

Salvare il file e uscire.

Avviare nuovamente il server web Apache:

$ sudo systemctl restart apache2

1 commento

LASCIA UN COMMENTO

Per favore, inserisci il tuo commento!
Per favore, inserisci il tuo nome qui

*